DDI_INTR_HILEVEL(9F) Kernel Functions for Drivers DDI_INTR_HILEVEL(9F)

NAME


ddi_intr_hilevel - indicate interrupt handler type

SYNOPSIS


#include <sys/ddi.h>
#include <sys/sunddi.h>


int ddi_intr_hilevel(dev_info_t *dip, uint_t inumber);


INTERFACE LEVEL


illumos DDI specific (illumos DDI). This interface is obsolete. Use
the new interrupt interfaces referenced in Intro(9F). Refer to
Writing Device Drivers for more information.

PARAMETERS


dip
Pointer to dev_info structure.


inumber
Interrupt number.


DESCRIPTION


The ddi_intr_hilevel() function returns non-zero if the specified
interrupt is a "high level" interrupt.


High level interrupts must be handled without using system services
that manipulate thread or process states, because these interrupts
are not blocked by the scheduler.


In addition, high level interrupt handlers must take care to do a
minimum of work because they are not preemptable.


A typical high level interrupt handler would put data into a circular
buffer and schedule a soft interrupt by calling
ddi_trigger_softintr(). The circular buffer could be protected by
using a mutex that was properly initialized for the interrupt
handler.


The ddi_intr_hilevel() function can be used before calling
ddi_add_intr() to decide which type of interrupt handler should be
used. Most device drivers are designed with the knowledge that the
devices they support will always generate low level interrupts,
however some devices, for example those using SBus or VME bus level 6
or 7 interrupts must use this test because on some machines those
interrupts are high level (above the scheduler level) and on other
machines they are not.

RETURN VALUES


non-zero
indicates a high-level interrupt.


CONTEXT


These functions can be called from useruser, interrupt, or kernel
context.

ATTRIBUTES


See attributes(7) for descriptions of the following attributes:


+--------------------+-----------------+
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
+--------------------+-----------------+
|Interface Stability | Obsolete |
+--------------------+-----------------+

SEE ALSO


Intro(9F), ddi_add_intr(9F), mutex(9F)


Writing Device Drivers

January 16, 2006 DDI_INTR_HILEVEL(9F)

tribblix@gmail.com :: GitHub :: Privacy