NET_INSTANCE_UNREGISTER(9F) Kernel Functions for Drivers

NAME


net_instance_unregister - disable a set of instances

SYNOPSIS


#include <sys/neti.h>

void net_instance_unregister(net_instance_t *instances);


INTERFACE LEVEL


illumos DDI specific (illumos DDI).

PARAMETERS


instances
must be a pointer returned by net_instance_alloc(9F).


DESCRIPTION


The net_instance_unregister() function removes the set of instances
that were previously registered with the net_instance_register()
function.

RETURN VALUES


If the net_instance_unregister() function succeeds, 0 is returned.
Otherwise, an error indicating the problem encountered.

CONTEXT


The net_instance_unregister() function may be called from user,
kernel, or interrupt context.

ATTRIBUTES


See attributes(7) for descriptions of the following attributes:


+--------------------+-----------------+
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
+--------------------+-----------------+
|Interface Stability | Committed |
+--------------------+-----------------+

SEE ALSO


attributes(7), net_instance_alloc(9F), net_instance_register(9F),
net_instance_t(9S)

May 1, 2008 NET_INSTANCE_UNREGISTER(9F)

tribblix@gmail.com :: GitHub :: Privacy